#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z\/\/:\.]*youtu(?:be\.com\/watch\?v=|\.be\/)([a-zA-Z0-9\-_]+)(?![^<]*>)"
Local $sString = "Hello world!" & @CRLF & _
"" & @CRLF & _
"<a href="https://www.youtube.com/watch?v=m7t75u72vd">ABC</a>" & @CRLF & _
"" & @CRLF & _
"Blah blah blah..." & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=df82vnx07s" & @CRLF & _
"" & @CRLF & _
"Blah blah blah..." & @CRLF & _
"<p>https://www.youtube.com/watch?v=nvs70fh17f3fg</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")