# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-zA-Z\/\/:\.]*youtu(?:be\.com\/watch\?v=|\.be\/)([a-zA-Z0-9\-_]+)(?![^<]*>)"
test_str = ("Hello world!\n\n"
"<a href=\"https://www.youtube.com/watch?v=m7t75u72vd\">ABC</a>\n\n"
"Blah blah blah...\n\n"
"https://www.youtube.com/watch?v=df82vnx07s\n\n"
"Blah blah blah...\n"
"<p>https://www.youtube.com/watch?v=nvs70fh17f3fg</p>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.