import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((@[\\w\\d][\\w\\d_]+)\\s+)?(\\.[\\w\\d][\\w\\d_]+\\s+)";
final String string = "@array .byte 3, 4, 23\n"
+ "va1 .byte 'A', -3, 0xAB // Three bytes\n"
+ "@str1 .byte \"Enter an integer: \" // Null-terminated string\n"
+ "@var2 .hword 0xABCD:10 // 0xABCD is replicated 10 times\n"
+ "@var3 .word -18, 5.7E-3 // 4-byte integer, single float\n"
+ "@var4 .dword 21, 21.0 // 8-byte integer, double float\n\n"
+ "//Assembly Language Syntax:\n"
+ "J @label // Jump @label\n"
+ "JAL @label // R31 = (PC+4); Jump @label\n"
+ "The JAL instruction saves the return address ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}