using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<operator> [A-Z]+ (?=([^\""]*\""[^\""]*\"")*[^\""]*$))";
string input = @"method(ARG,""No AND Yes OR other"") OR method(ARG,ARG) AND method(ARG,ARG)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}