package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^[:space:]=]+=([^[:space:]]+)`)
var str = `DROP IN=eth0 OUT= MAC=00:00:64:34:65:f8:00:00:5c:6f:36:46:08:00 SRC=6.6.73.64 DST=45.45.89.250 LEN=40 TOS=0x00 PREC=0x20 TTL=235 ID=2329 PROTO=TCP`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}