re = /[^[:space:]=]+=([^[:space:]]+)/m
str = 'DROP IN=eth0 OUT= MAC=00:00:64:34:65:f8:00:00:5c:6f:36:46:08:00 SRC=6.6.73.64 DST=45.45.89.250 LEN=40 TOS=0x00 PREC=0x20 TTL=235 ID=2329 PROTO=TCP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end