package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?(DEFINE)
(?<weeks>mon|tue|wed|thu|fri|sat|sun)
)
^(?P<weekdays>
(?:
\b
(?&weeks)
(?:\.\.(?&weeks))?
,?
)*
)$`)
var str = `mon,mon..tue`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}