re = /(?(DEFINE)
(?<weeks>mon|tue|wed|thu|fri|sat|sun)
)
^(?P<weekdays>
(?:
\b
(?&weeks)
(?:\.\.(?&weeks))?
,?
)*
)$/ix
str = 'mon,mon..tue'
# Print the match result
str.match(re) do |match|
puts match.to_s
end