#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\d{2}([-\/])\d{2}(?:\1)\d{4})(?:((?:(?:0[13578]|1[02])[-\/](?:0[1-9]|[1-2]\d|3[01])|(?:0[469]|11)[-\/](?:0[1-9]|[1-2]\d|30)|02[-\/](?:0[1-9]|[1-2]\d))[-\/])(?:19\d{2}|200[0-4])|(?!09[-\/](?:19|2|3)|1)(?-1)2005)$"
Local $sString = "MATCH:" & @CRLF & _
"09/18/2005" & @CRLF & _
"08/05/2004" & @CRLF & _
"01/01/2000" & @CRLF & _
"01/02/1934" & @CRLF & _
"09-18-2005" & @CRLF & _
"12/13/2000" & @CRLF & _
"12/31/2000" & @CRLF & _
"12-31-2000" & @CRLF & _
"11/30/2000" & @CRLF & _
"02/28/2002" & @CRLF & _
"02/29/2002" & @CRLF & _
"04-30-2005" & @CRLF & _
"06/04/1987" & @CRLF & _
"10/23/1999" & @CRLF & _
"02/25/2004" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"NO MATCH:" & @CRLF & _
"01/01/2006" & @CRLF & _
"09/19/2005" & @CRLF & _
"09/25/2005" & @CRLF & _
"09-19-2005" & @CRLF & _
"09-18/2005" & @CRLF & _
"09/18-2005" & @CRLF & _
"10/20/2005" & @CRLF & _
"08/34/2004" & @CRLF & _
"01/00/2000" & @CRLF & _
"00/01/2000" & @CRLF & _
"001/01/2000" & @CRLF & _
"01/001/2000" & @CRLF & _
"13/14/2000" & @CRLF & _
"12/32/2000" & @CRLF & _
"11/31/2000" & @CRLF & _
"11/30/ 2000" & @CRLF & _
"01/02/1834" & @CRLF & _
"02/30/2002" & @CRLF & _
"04-31-2005" & @CRLF & _
"09/18/2023" & @CRLF & _
"06/23/2008" & @CRLF & _
"04/03/2026"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")