re = /\n(?=(?:.+\n.+\n)*.+$)/
str = 'LINE1
LINE2
LINE3
LINE4
LINE5
LINE6'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result