import Foundation
let pattern = #"\n(?=(?:.+\n.+\n)*.+$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
LINE1
LINE2
LINE3
LINE4
LINE5
LINE6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)