package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\d]?\.?\d*(?:g|(?<p>\()(?(p)g\/(?:\d+)?ml\)))?`)
var str = `0, 1, 0.1, .1, 1g, 0.1g, .1g, 1(g/100ml), .1(g/ml)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}