$re = '/(\[.+?])\$\((https?[^\s]+)\)/m';
$str = '**For more: [Click here]$(https://www.google.ca) and [click me]$(https://www.google.com)**
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);