re = /(\[.+?])\$\((https?[^\s]+)\)/m
str = '**For more: [Click here]$(https://www.google.ca) and [click me]$(https://www.google.com)**
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end