const regex = /^(?:[^_\n]*_){3}[^_\n]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^_\\n]*_){3}[^_\\n]*$', 'gm')
const str = `this_is_quite_valid
this_ain't_valid
___what
no__that's__enough
___stooooop___
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}