$re = '/^(?:[^_\n]*_){3}[^_\n]*$/m';
$str = 'this_is_quite_valid
this_ain\'t_valid
___what
no__that\'s__enough
___stooooop___
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);