$re = '/^(?!.*"").*$/m';
$str = 'This is a "Example" text!
Good This is a ""Example"" text! - Bad
"
""
"a""
""a
""
"a"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);