re = /^(?!.*"").*$/m
str = 'This is a "Example" text!
Good This is a ""Example"" text! - Bad
"
""
"a""
""a
""
"a"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end