#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miU)^\/prifix\/([a-zA-Z0-9_\-\!\.\/]+)\/{0,1}((\/(full|square|([1-9]\d*|0),([1-9]\d*|0),([1-9]\d*),([1-9]\d*)|pct:(([1-9]\d*|0)(\.\d+)?),(([1-9]\d*|0)(\.\d+)?),([1-9]\d{0,1}(\.\d*)?|0\.[0]*[1-9]+|100(\.0+)?),([1-9]\d{0,1}(\.\d*)?|0\.[0]*[1-9]+|100(\.0+)?)|(\w+))\/(full|max|([1-9]\d*),|,([1-9]\d*)|(\!)?([1-9]\d*),([1-9]\d*)|pct:(([1-9]\d*)(\.\d+)?)|(\w+))\/(\!)?([1-9]\d*|0|(\w+))(\.\d+)?\/(default|color|gray|bitonal|(\w+))\.(jpg|tif|png|webp|pdf|jp2|(\w+)))|info\.json){0,1}$"
Local $sString = "/prifix/imageID/1024,1024,1024,1024/1024,1024/0/default.jpg" & @CRLF & _
"/prifix/imageID/1024,1024,1024,1024/!1024,1024/0/default.jpg" & @CRLF & _
"/prifix/imageID/1024,1024,1024,1024/1024,/0/default.jpg" & @CRLF & _
"/prifix/imageID/1024,1024,1024,1024/,1024/0/default.jpg" & @CRLF & _
"/prifix/imageID/full/PCT:50/0/default.jpg" & @CRLF & _
"/prifix/imageID/SqUarE/1024,/0/deFAult.jPg" & @CRLF & _
"/prifix/imageID/SqUarE/,1024/0/deFAult.jPg" & @CRLF & _
"/prifix/imageID/SqUarE/1024,2048/0/deFAult.jPg" & @CRLF & _
"/prifix/imageID/SqUarE/full/0/deFAult.jPg" & @CRLF & _
"/prifix/imageID/inFo.json" & @CRLF & _
"/prifix/imageID/" & @CRLF & _
"/prifix/imageID" & @CRLF & _
"/prifix/errorFormate/aaa/bbb/ccc/ddd.jpg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")