import re
regex = re.compile(r"^\/prifix\/([a-zA-Z0-9_\-\!\.\/]+)\/{0,1}((\/(full|square|([1-9]\d*|0),([1-9]\d*|0),([1-9]\d*),([1-9]\d*)|pct:(([1-9]\d*|0)(\.\d+)?),(([1-9]\d*|0)(\.\d+)?),([1-9]\d{0,1}(\.\d*)?|0\.[0]*[1-9]+|100(\.0+)?),([1-9]\d{0,1}(\.\d*)?|0\.[0]*[1-9]+|100(\.0+)?)|(\w+))\/(full|max|([1-9]\d*),|,([1-9]\d*)|(\!)?([1-9]\d*),([1-9]\d*)|pct:(([1-9]\d*)(\.\d+)?)|(\w+))\/(\!)?([1-9]\d*|0|(\w+))(\.\d+)?\/(default|color|gray|bitonal|(\w+))\.(jpg|tif|png|webp|pdf|jp2|(\w+)))|info\.json){0,1}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("/prifix/imageID/1024,1024,1024,1024/1024,1024/0/default.jpg\n"
"/prifix/imageID/1024,1024,1024,1024/!1024,1024/0/default.jpg\n"
"/prifix/imageID/1024,1024,1024,1024/1024,/0/default.jpg\n"
"/prifix/imageID/1024,1024,1024,1024/,1024/0/default.jpg\n"
"/prifix/imageID/full/PCT:50/0/default.jpg\n"
"/prifix/imageID/SqUarE/1024,/0/deFAult.jPg\n"
"/prifix/imageID/SqUarE/,1024/0/deFAult.jPg\n"
"/prifix/imageID/SqUarE/1024,2048/0/deFAult.jPg\n"
"/prifix/imageID/SqUarE/full/0/deFAult.jPg\n"
"/prifix/imageID/inFo.json\n"
"/prifix/imageID/\n"
"/prifix/imageID\n"
"/prifix/errorFormate/aaa/bbb/ccc/ddd.jpg\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")