#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)([^\pL\pN\pP\pS\pZ])|([\xC2\xA0])"
Local $sString = "line_1" & @CRLF & _
"line_2"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)