const regex = /^([a-z0-9]|[a-z0-9](-(?!-)|[a-z0-9]){0,37}[a-z0-9])\/[a-z0-9-]{1,39}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z0-9]|[a-z0-9](-(?!-)|[a-z0-9]){0,37}[a-z0-9])\\\/[a-z0-9-]{1,39}$', 'gmi')
const str = `reduxjs/react-redux
gimir/meat-page
gimir/portfolio
redu--xjs/react-redux
gim-ir/meat-page
-gimir/portfolio
gimir-/portfolio
aa/portfolio
a/portfolio
Поисковой запрос должен быть таким: owner/repository
требования для owner:
- максимальная длина 39
- может содержать цифры от 0 до 9, все латинские буквы и дефис "-"
-не должен начинаться и заканчиваться на дефис
-не должно быть сразу двух дефисов вместе, типа "--"
После owner обязательно должен стоять "/"
Требования для repository:
- максимальная длина 39
- может содержать цифры, лат. буквы и дефис ( в отличии от owner, дефис может повторяться и стоять как в начале так и в конце).
Битый час бился над этой проблемой, никак не получается, кто может помочь?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}