import Foundation
let pattern = #"^([a-z0-9]|[a-z0-9](-(?!-)|[a-z0-9]){0,37}[a-z0-9])\/[a-z0-9-]{1,39}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
reduxjs/react-redux
gimir/meat-page
gimir/portfolio
redu--xjs/react-redux
gim-ir/meat-page
-gimir/portfolio
gimir-/portfolio
aa/portfolio
a/portfolio
Поисковой запрос должен быть таким: owner/repository
требования для owner:
- максимальная длина 39
- может содержать цифры от 0 до 9, все латинские буквы и дефис "-"
-не должен начинаться и заканчиваться на дефис
-не должно быть сразу двух дефисов вместе, типа "--"
После owner обязательно должен стоять "/"
Требования для repository:
- максимальная длина 39
- может содержать цифры, лат. буквы и дефис ( в отличии от owner, дефис может повторяться и стоять как в начале так и в конце).
Битый час бился над этой проблемой, никак не получается, кто может помочь?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)