$re = '/(?:[^_\ ]+)(?:\ )(?:[^_\ ]+), (?:[^_\ ]+)-PRT-[^_\ ](?:[^_\ ]*)/i';
$str = 'word anotherword, xyz1-prt-onemoreword-500 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);