re = /(?:[^_\ ]+)(?:\ )(?:[^_\ ]+), (?:[^_\ ]+)-PRT-[^_\ ](?:[^_\ ]*)/i
str = 'word anotherword, xyz1-prt-onemoreword-500 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end