$re = '/^((^|(?<!^),)\s*(АБС|ДДФ|ЯС|ОПП|ШЦЦР|ССД)\s*)+$/';
$str = 'АБС, ДДФ, ЯС, ОПП, ШЦЦР, ССД, ССД';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);