re = /^((^|(?<!^),)\s*(АБС|ДДФ|ЯС|ОПП|ШЦЦР|ССД)\s*)+$/
str = 'АБС, ДДФ, ЯС, ОПП, ШЦЦР, ССД, ССД'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end