import re
regex = re.compile(r"Domaine\s?([A-Za-z\u00C0-\u017F]+)")
test_str = ("T. G. \n"
"Consultant JAVA/J2EE \n"
" \n"
"Anglais/Français/Chinois \n"
" \n"
"SYNTHESE \n"
" Programmeur et analyste JAVA/J2EE \n"
" Conception d’architectures Web \n"
" Domaine immobilier et bancaire \n"
" \n"
"FORMATION ET LANGUES \n"
" \n"
"2005-2007 Maîtrise en Génie Informatique, École Polytechnique de Montréal, Canada \n"
"2003-2004 Licence en Informatique, Université Denis Diderot (Paris, France) \n"
"1996-2000 Licence en EEA (Automatisme, Electronique), Université de Science et Technologie de Dalian, \n"
"Chine \n"
" \n"
"DOMAINE D’EXPERTISE \n"
" \n"
" Systèmes Unix (SUSE), Linux, Windows 9X/NT/2000/XP/Vista, Max OS \n"
" Protocoles LAN, WAN, HTTP, TCP/IP, SMTP, POP3 \n"
" Langages Java, Html, JavaScript, Sql, C, C++, Perl, XML (DOM, SAX) \n"
" JAVA/J2EE Java, JSP, Servlet, JDBC, Swing, JUnit, Maven, Ant \n"
" Framework Struts, Hibernate, Spring, Webwork \n"
" Web: Ajax, CSS, Prototype, Php5 \n"
" Bases de Données Oracle 9i/10G, MySql, SqlServer \n"
" Serveurs d’applic Apache, Tomcat, JBoss, Weblogic \n"
" IDE Eclipse, MyEclipse, Visual Studio, CVS, Visio \n"
" Méthodes UML (Use Case, diagrammes de classes/séquences/activité), Agile/Scrum \n"
" \n"
" \n"
"EXPERIENCE PROFESSIONNELLE \n"
"Janvier 2008 à ce jour : Logiciels Prospects Inc, Montreal \n"
" \n"
"Programmeur Analyste JAVA/J2EE, Projet \"Prospects Web\", Solution destinée aux agents immobiliers \n"
"pour la gestion des contacts, des activités et des propriétés, au sein d’une équipe de 16 personnes \n"
"composée d’un Lead technical, 2 QA, 6 développeurs chef . \n"
" \n"
"Prospects Web est un outil qui vise à gérer et simplifier le travail d’un agent immobilier. Cette application est \n"
"réalisée avec les technologies J2EE et utilise plusieurs Framework de Apache. Cet outil a deux versions : une \n"
"version de base et une version professionnelle. La version de base offre des fonctionnalités de gestion des \n"
"contacts et des propriétés, un système courriel et un calendrier personnel. La version professionnelle offre en \n"
"plus des fonctionnalités comme l’évaluation du marché, l’analyse des ventes, la gestion des documents et le \n"
"match (trouver automatiquement les inscriptions satisfaits aux critères de recherche). L’application possède \n"
"aussi une interface qui permet aux usagers de synchroniser les activités et les contacts avec leurs appareils \n"
"mobiles. Ce système est utilisé par plusieurs chambres immobilières au Canada et aux États-Unis. ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")