# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^\.]*\.){2}(?<All>.*)"
test_str = (" TMS_KEP.Male_RTU2.Male_PRM1_GL_OUT\n"
" TMS_KEP.Male_RTU2.Male_PRM1_PS_IN\n"
" TMS_KEP.Female_RTU2.Female_WC8_RL_OUT\n"
" TMS_KEP.Male_RTU1.Male_WC3_FS_OUT\n"
" TMS_KEP.Male_RTU1.Male_WC5_FS_OUT")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.