re = /([^\.]*\.){2}(?<All>.*)/
str = ' TMS_KEP.Male_RTU2.Male_PRM1_GL_OUT
TMS_KEP.Male_RTU2.Male_PRM1_PS_IN
TMS_KEP.Female_RTU2.Female_WC8_RL_OUT
TMS_KEP.Male_RTU1.Male_WC3_FS_OUT
TMS_KEP.Male_RTU1.Male_WC5_FS_OUT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end