import re
regex = re.compile(r"Serial Number: (\S*)$", flags=re.MULTILINE)
test_str = ("Cisco Adaptive Security Appliance Software Version 9.12(1)2 \n"
"ASAv1 up 23 mins 50 secs\n"
"Serial Number: 9A2AL26E95V")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")