#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*As)(?=.*[^A]s)"
Local $sString = "AsKcQsJd" & @CRLF & _
"" & @CRLF & _
"AsKcQsJs" & @CRLF & _
"" & @CRLF & _
"AsKcQdJd" & @CRLF & _
"" & @CRLF & _
"KsKcQdJd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")