$re = '/(?=.*As)(?=.*[^A]s)/m';
$str = 'AsKcQsJd
AsKcQsJs
AsKcQdJd
KsKcQdJd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);