package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[Monitor Status\]\(/monitors#(\d+)`)
var str = `[Monitor Status](/monitors#2972550?)] · [[Edit Monitor](/monitors#2972550/edit)] · [[Related Logs](/logs?query=)]
%%%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}