re = /\[Monitor Status\]\(\/monitors#(\d+)/
str = '[Monitor Status](/monitors#2972550?)] · [[Edit Monitor](/monitors#2972550/edit)] · [[Related Logs](/logs?query=)]
%%%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end