import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<timeHour>\\d{1,2}):(?<timeMinute>\\d{2})(?:\\:(?<timeSecond>\\d{2}))?\\s+up\\s+(?:(?<upDays>\\d+)\\s+days?,\\s+)?\\b(?:(?<upHours>\\d+):)?(?<upMinutes>\\d+)(?:\\s+min?)?,\\s+.+?(?<load1>\\d+\\.\\d+),?\\s+(?<load2>\\d+\\.\\d+),?\\s+(?<load3>\\d+\\.\\d+)\n";
final String string = "15:05 up 1 day, 10:40, 4 users, load averages: 1.68 1.30 1.30\n"
+ "12:27:57 up 25 min, load average: 0.33, 0.33, 0.28\n"
+ "12:27:58 up 1:26, load average: 5.44, 5.29, 5.26\n"
+ "00:36:55 up 16 days, 26 min, load average: 0.83, 0.75, 0.76\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}