// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<timeHour>\d{1,2}):(?<timeMinute>\d{2})(?:\:(?<timeSecond>\d{2}))?\s+up\s+(?:(?<upDays>\d+)\s+days?,\s+)?\b(?:(?<upHours>\d+):)?(?<upMinutes>\d+)(?:\s+min?)?,\s+.+?(?<load1>\d+\.\d+),?\s+(?<load2>\d+\.\d+),?\s+(?<load3>\d+\.\d+)
").unwrap();
let string = "15:05 up 1 day, 10:40, 4 users, load averages: 1.68 1.30 1.30
12:27:57 up 25 min, load average: 0.33, 0.33, 0.28
12:27:58 up 1:26, load average: 5.44, 5.29, 5.26
00:36:55 up 16 days, 26 min, load average: 0.83, 0.75, 0.76
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}