using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Q:[^\S\n]+(.+(?:\r?\n(?![QA]:[^\S\n]+).+)*)(?:\r?\n+(?![QA]:[^\S\n]+).+)*\n+A:[^\S\n](.+(?:\n(?![QA]:[^\S\n]+).+)*)";
string input = @"Q: How do you use this style?
A: Just like this.
Q: Can the question
run over multiple lines?
A: Yes, and
So can the answer
Q: Does the answer need to be immediately after the question?
A: No, and preceding whitespace will be ignored.
Q: This is my question
This is my second line of my question and my question will end when i use this 3 dots, but i dont have to use it, if no additional text is between Q: & A: °°°
This is additional text on a new line, which should not be detected as a part of my question or answer, nor should it destroy the functionality.
This is a test
A: This is my Answer.
My second line of the Answer °°° This is additional Text on the same line, which should not be detectet as my Answer. So as you can see, it should be possible to make an additional text on the same line, but also on a new line.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}