import re
regex = re.compile(r"^Q:[^\S\n]+(.+(?:\r?\n(?![QA]:[^\S\n]+).+)*)(?:\r?\n+(?![QA]:[^\S\n]+).+)*\n+A:[^\S\n](.+(?:\n(?![QA]:[^\S\n]+).+)*)", flags=re.MULTILINE)
test_str = ("Q: How do you use this style?\n"
"A: Just like this.\n\n"
"Q: Can the question\n"
"run over multiple lines?\n"
"A: Yes, and\n"
"So can the answer\n\n"
"Q: Does the answer need to be immediately after the question?\n\n\n"
"A: No, and preceding whitespace will be ignored.\n\n"
"Q: This is my question\n"
"This is my second line of my question and my question will end when i use this 3 dots, but i dont have to use it, if no additional text is between Q: & A: °°°\n\n"
"This is additional text on a new line, which should not be detected as a part of my question or answer, nor should it destroy the functionality.\n\n"
"This is a test\n\n"
"A: This is my Answer.\n"
"My second line of the Answer °°° This is additional Text on the same line, which should not be detectet as my Answer. So as you can see, it should be possible to make an additional text on the same line, but also on a new line.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")