using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/[a-zA-Z0-9-:\/.=?_]+,\s(http:\/\/[a-zA-Z0-9-:\/.=?_]+),\shttp:\/\/[a-zA-Z0-9-:\/.=?_]+";
string input = @"http://abc.com/main_img_a, http://abc.com/altimg_a_1, http://abc.com/altimg_a_2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}