import re
regex = re.compile(r"http:\/\/[a-zA-Z0-9-:\/.=?_]+,\s(http:\/\/[a-zA-Z0-9-:\/.=?_]+),\shttp:\/\/[a-zA-Z0-9-:\/.=?_]+", flags=re.MULTILINE)
test_str = "http://abc.com/main_img_a, http://abc.com/altimg_a_1, http://abc.com/altimg_a_2"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")