package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{3}\s[0-9]{4}\s[0-9]{5}`)
var str = `"price":888 9999 10100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}