$re = '/[0-9]{3}\s[0-9]{4}\s[0-9]{5}/m';
$str = '"price":888 9999 10100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);