const regex = /\b(19|20)[0-9]{2}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(19|20)[0-9]{2}\\b', 'g')
const str = `"AW: MV37417405 - Werk 050 2017 LN 154/60231"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}