$re = '/\b(19|20)[0-9]{2}\b/';
$str = '"AW: MV37417405 - Werk 050 2017 LN 154/60231"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);