using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+:\d+ [AP]M";
string input = @"SomeText 02/02/2020 9:00 AM-02/02/2020 9:15 AM;""Text"" 02/02/2020 10:45 AM-02/02/2020 11:15 AM;""Text"" 02/02/2020 12:45 PM-02/02/2020 1:00 PM;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}