// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+:\d+ [AP]M").unwrap();
let string = "SomeText 02/02/2020 9:00 AM-02/02/2020 9:15 AM;\"Text\" 02/02/2020 10:45 AM-02/02/2020 11:15 AM;\"Text\" 02/02/2020 12:45 PM-02/02/2020 1:00 PM;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}