import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Booking Voucher Number: (?<number>\\d\\d\\d\\d\\d\\d\\d\\d\\d\\d)|(Guest Name : (?<name>\\w\\w.*))|(Check In Date : (?<date>\\d{4}-\\d{2}-\\d{2}))|(Check Out Date : (?<Outdate>\\d{4}-\\d{2}-\\d{2}))|(Number of Rooms : (?<RoomNumbers>)\\d.*)|(Special Request : (?<SRQST>\\w.*))|(paid for Guests: (?<PfG>)\\d.*)|(Room Type : (?<RoomType>)\\w.*)";
final String string = "Booking Voucher Number: 2052892268 \n"
+ "Guest Name : Maxie Dibbert \n"
+ "Check In Date : 2018-11-09 \n"
+ "Check Out Date : 2018-11-10 \n"
+ "Number of Rooms : 14 \n"
+ "Booking Type : Pay At Hotel Amount To Be Collected : 91.2 (SOD) \n"
+ "Special Request : NA \n"
+ "Breakfast Included: No Breakfast \n"
+ "paid for Guests: 0 \n"
+ "Room Type : Single Bed in Female Dormitory \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}