import re
regex = re.compile(r"Booking Voucher Number: (?<number>\d\d\d\d\d\d\d\d\d\d)|(Guest Name : (?<name>\w\w.*))|(Check In Date : (?<date>\d{4}-\d{2}-\d{2}))|(Check Out Date : (?<Outdate>\d{4}-\d{2}-\d{2}))|(Number of Rooms : (?<RoomNumbers>)\d.*)|(Special Request : (?<SRQST>\w.*))|(paid for Guests: (?<PfG>)\d.*)|(Room Type : (?<RoomType>)\w.*)", flags=re.MULTILINE)
test_str = ("Booking Voucher Number: 2052892268 \n"
"Guest Name : Maxie Dibbert \n"
"Check In Date : 2018-11-09 \n"
"Check Out Date : 2018-11-10 \n"
"Number of Rooms : 14 \n"
"Booking Type : Pay At Hotel Amount To Be Collected : 91.2 (SOD) \n"
"Special Request : NA \n"
"Breakfast Included: No Breakfast \n"
"paid for Guests: 0 \n"
"Room Type : Single Bed in Female Dormitory \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")