$re = '/^(?!.*square).*front/m';
$str = 'foo bar front
abc pqr
foo bar front square
foo bar square front
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);